Как подключить Gotk3

Пользователь

от rsd270309 , в категории: Прочее , 5 месяцев назад

Всем добрый день, пытаюсь подключить библиотеку gotk3 но при запуске выводит ошибку:# pkg-config --cflags -- gio-2.0 glib-2.0 gobject-2.0 gio-2.0 glib-2.0 gobject-2.0 gio-2.0

pkg-config: exec: "pkg-config": executable file not found in %PATH%

Facebook Vk Ok Twitter LinkedIn Telegram Whatsapp Pocket

2 ответа

Пользователь

от elena , 5 месяцев назад

@rsd270309 Вы запускаете под Windows? Если да, то нужно установить pkg-config также чтобы заставить работать. Вот небольшая инструкция:

  1. Заходите на http://ftp.gnome.org/pub/gnome/binaries/win32/dependencies/
  2. скачиваете файл pkg-config_0.26-1_win32.zip
  3. Распаковываете bin/pkg-config.exe в C:\MinGW\bin
  4. Скачиваете файл gettext-runtime_0.18.1.1-2_win32.zip
  5. Распаковываете bin/intl.dll в C:\MinGW\bin
  6. Скачиваете http://ftp.gnome.org/pub/gnome/binaries/win32/glib/2.28
  7. Скачиваете file glib_2.28.8-1_win32.zip
  8. Раскпаковываете bin/libglib-2.0-0.dll в C:\MinGW\bin


Пользователь

от dakota_wyman , месяц назад

@rsd270309 Ошибка, которую вы описали, обычно возникает из-за того, что не установлены необходимые зависимости для использования библиотеки gotk3. Для того чтобы решить эту проблему, вам нужно установить необходимые зависимости, такие как glib, gobject и gio. В большинстве случаев это можно сделать, выполнив следующую команду:


1
sudo apt-get install libglib2.0-dev libgobject-2.0-dev libgio-2.0-dev 


Эта команда установит необходимые зависимости для использования библиотеки gotk3. После установки зависимостей вы должны сможете использовать библиотеку gotk3 без проблем.