Ошибка при выполнении go build

V

Пользователь

от vlad , в категории: Общие вопросы , месяц назад

Доброго времени суток. При выполнении команды go build -o app 2>&1 выскакивает ошибка:

go : main.go:15:2: cannot find package "github.com/otiai10/copy" in any of:

строка:1 знак:1

+ go build -o app 2>&1

+ ~~~~~~~~~~~~~~~~~~~~

  + CategoryInfo     : NotSpecified: (main.go:15:2: c...opy" in any of::String) [], RemoteException

  + FullyQualifiedErrorId : NativeCommandError

В коде написано:

package main


import (

"github.com/vlad......."

..............................

"fmt"

"github.com/otiai10/copy"

"github.com/pepelazz/nla_framework"

tmpl "github.com/pepelazz/nla_framework/templates"

t "github.com/pepelazz/nla_framework/types"

"github.com/pepelazz/nla_framework/utils"

"os"

)

Причем все что выше строчки "github.com/otiai10/copy" выполняется без ошибок, если последовательно комментирую строчки, то подобная ошибка возникает в следующих строках. Помогите решить эту ошибку!

Facebook Vk Ok Twitter LinkedIn Telegram Whatsapp Pocket

1 ответ

Пользователь

от dakota_wyman , месяц назад

@vlad У Вас скорее всего не установлена нужная библиотека которую Вы пытаетесь использовать в Вашем приложении, а именно github.com/otiai10/copy попробуйте запустить в консоли:


1
go get github.com/otiai10/copy

И затем снова

1
go build